Forum

XP400's Won't Turn on help

XP400's Won't Turn on help

Postby cesarf95 » Thu Dec 27, 2012 5:15 pm

I just got them yesterday and they were working fine in the afternoon , now i tried to play and they won't turn on at all I left it charging while i was gone, what should i do ?
cesarf95
 
Posts: 1
Joined: Thu Dec 27, 2012 5:13 pm

Re: XP400's Won't Turn on help

Postby taco8510 » Mon Jan 14, 2013 6:30 pm

I am not sure if you need help or not still. But I had the same problem as you and I freaked out as they are pretty new.

I turned to the manual and read the troubleshooting just so you know where I got it from. It says to use the Mute Button. So hold the mute button for 10 seconds and it is a force shutdown. I know they are already shutdown..but desperate people try whatever they can.

It worked for me so give it a shot.
taco8510
 
Posts: 1
Joined: Mon Jan 14, 2013 6:27 pm

Re: XP400's Won't Turn on help

Postby hannibaldark » Wed Mar 27, 2013 9:58 am

I've currently run into a problem with this headset I came home turned everything on including the headset went into the kitchen for 15-20 min headset did its auto turn off by then went to turn it back on and its become unresponsive it won't turn on or force shut down. Battery is charged as well.
hannibaldark
 
Posts: 1
Joined: Wed Mar 27, 2013 9:52 am

Re: XP400's Won't Turn on help

Postby TB_EggShen » Thu Mar 28, 2013 4:03 pm

hannibaldark wrote:I've currently run into a problem with this headset I came home turned everything on including the headset went into the kitchen for 15-20 min headset did its auto turn off by then went to turn it back on and its become unresponsive it won't turn on or force shut down. Battery is charged as well.


Get in touch with tech support and they'll help you get back up and running: http://www.turtlebeach.com/contact-support
Social Media Marketing Zombie for Turtle Beach
Twitter: @heyeggshen
User avatar
TB_EggShen
 
Posts: 1708
Joined: Wed Nov 21, 2012 3:43 pm

Re: XP400's Won't Turn on help

Postby xXPONYBOY » Sun May 12, 2013 10:07 am

Im hoping the fix for this doesn't involve buying a new $250 gaming headset.
xXPONYBOY
 
Posts: 6
Joined: Sat May 11, 2013 10:12 pm

Re: XP400's Won't Turn on help

Postby blkgto » Thu Aug 15, 2013 10:30 pm

I am having this problem too. I was playing battlefield 3 and they just shut off. Would not turn back on. They should now be fully charged. I did the hard shut down with the mute button, and they still won't come back on. I have contacted tech support but its still a tremendous bummer, they are not even a year old. They also have put the serial number in about the dumbest place possible. This is kind of unacceptable for a pair of headphones that costs this much. I expect them to be replaced, or I will just go buy a different brand.
blkgto
 
Posts: 1
Joined: Thu Aug 15, 2013 10:27 pm

Re: XP400's Won't Turn on help

Postby gamerx32104 » Sun Aug 18, 2013 12:26 am

I currently use the XP400s and luckily have had zero issues thus far. After reading some of the posts above I am glad I buy my headsets at Best Buy along with their two year replacement plan. Before my XP400s I tried Astro A50s and had no problem exchanging them when they became defective. I figure even if I have zero issues with my headset that I will still return them right before my replacement plan ends for eithera new pair or newer model.
gamerx32104
 
Posts: 113
Joined: Sat Jan 19, 2013 2:21 am

Re: XP400's Won't Turn on help

Postby tyler_gullion » Fri Dec 27, 2013 12:12 am

I am having the same problem and mine says its charging due to the red dot once I plug it in but it turns off after a minute or so.I have tried the holding them you button and everything else but mine won't seem to work please help
tyler_gullion
 
Posts: 1
Joined: Thu Dec 26, 2013 11:58 pm


Return to Xbox Gaming Headsets

Who is online

Users browsing this forum: No registered users and 2 guests